[Feedback Requested] Updating videos for PyQt6/PySide6 ( &PySide2)

I’m currently working on updating the videos (including adding videos for all tutorials on the site & updating them for Qt6). One the issues is there are now 4 (!) variants of Qt for Python, with PyQt5, PySide2, PyQt6, PySide6.

Until Qt6 editions have feature parity I need to continue supporting Qt5.

For the books, the code snippets (for the most part) are auto-converted. Since I have a converter that works, I thought I could use that in the videos live to present both versions simultaneously. I’ve done a quick demo, and it would be great to get feedback on whether this feels like a good solution?

A short video is available here:

As I write the code in PyQt5, it is auto converted to PySide2, and PyQt6 (including the long-namespace names).

In the video I’m using 3 vertical panes auto-updating from the pyqt5 source (PyQt5, PySide2, PySide6). I think in practise this is too much. A grid of 4 is maybe better, but maybe that view is too small?

.

The views will be sync-scrolled and updated live.

If 4 is too much, I could possibly re-record separate videos for Qt5 and Qt6 versions?

Thoughts please!

I didn’t see anything wrong with the 3 vertical panes.
Just a little worry about the scroll not being horizontally synced, other than that I didn’t see anything wrong with the 3 panes. It was easy to follow.

I think the 3 vertical panes will work well. I don’t think it will be too noisy for newbees.

I think it works great, at first a little bit distracting since you of course want to see everything that changes and updates automatically, but when you realize that you need to focus on just one pane that contains the source for your Qt version, it’s fine.

Thanks for the feedback, great to hear! I’ve actually just split out the PySide tutorials into a separate “course” since with PyQt6 things were getting a bit busy – 4 versions per code block. Splitting them, many of the code blocks (without imports) are identical for both. So this means the videos will be two-pane PyQt5+PyQt6 and PySide2+PySide6.

Since the two libraries tend to be more compatible with themselves, it should make things easier to follow too.

1 Like